import Foundation
let pattern = #"^\s*|\s*$|\s*(\r?\n)\s*|(\s)\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Let's
make this
look
a little
nicer
and
more
readible
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)