"text"the literal text "text" (case sensitive) \s*any whitespace character, repeated any number of times
:the literal : (5810 / 728 / 3A16)
\s*any whitespace character, repeated any number of times
"Message Id:the literal text "Message Id: (case sensitive) \s*any whitespace character, repeated any number of times
Group messageId(?P<messageId>[^ ]+) Negated Character Class[^ ]+ +matches at least one character outside the set below:
the literal (3210 / 408 / 2016)
\s*any whitespace character, repeated any number of times
:the literal : (5810 / 728 / 3A16)
\s*any whitespace character, repeated any number of times
Group message(?P<message>INT(?P<INT>[^ ]+)[^,]+) INTthe literal text INT (case sensitive) Negated Character Class[^ ]+ +matches at least one character outside the set below:
the literal (3210 / 408 / 2016)
Negated Character Class[^,]+ +matches at least one character outside the set below:
,the literal , (4410 / 548 / 2C16)
,the literal , (4410 / 548 / 2C16)
\s*any whitespace character, repeated any number of times
source userthe literal text source user (case sensitive) g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string