package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<timestamp>(.*?))\|(?<level>(.*?))\|(?<language>(.*?))\|(?<service>(.*?))\|(?<uuid>(.*?))\|(?<message>.*)`)
var str = `2020-09-16 04:47:49 | info | PHP | BACKEND | 01ARZ3NDEKTSV4RRFFQ69G5FAV | Login not successfully. Please try again
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}