Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
[0-9]{2}\/[0-9]{2}\/[0-9]{4}
/
gm
Test String
New
Valid dates: 01/04/2020 20/01/2019 25/12/1950 30/07/2021 31/08/1919 01/01/1729 10/05/2000 15/10/2049 Invalid dates: 001/04/1900 01/004/1900 90/04/1900 33/04/1900 01/13/1900 01/04/19000 00/04/1900 01/00/1900 1/4/00 1/04/1900 10/4/1900 10/04/00 /// /04/1900 01//1900 01/04/ 01/04/1900 This is the date: 01/04/1900 01.04.1900 01-04-1900