import Foundation
let pattern = #"^\d{2}/\d{2}/\d{4}[- .]+\d{2}/\d{2}/\d{4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-- these should match:
11/13/2019 - 11/13/2019
11/14/2019 11/14/2019
01/21/2019. . 11/20/2019
-- these should *not* match:
something 11/14/2019 11/14/2019 something
111111/2/3 1/1/1
1/14/2019 11/14/2019
11/14/201911/14/2019
11/13/2019 -
11/13/2019
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)