import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)\\((\\?<(?<name>[\\w][\\w\\d_]+)>|(?=[^\\?]))";
final String string = "(?:(?<=s+)(?<template>Td{1,2})s+|(?<=\\()(?<ptemplate>Td{1,2})|(?:\\b(?<value>v\\d{1,2})\\b(.*)))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}