#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\((?=[^)]*[a-zA-Z ])[^)]+?\)"
Local $sString = "(3) will not be replaced" & @CRLF & _
"" & @CRLF & _
"(1234) will not be replaced" & @CRLF & _
"" & @CRLF & _
"(some letters) will be replaced" & @CRLF & _
"" & @CRLF & _
"(some letters, spaces - and numbers 123) will be replaced"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")