#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "hello\s+animals:\s+(?<!animals:)|(?P<hi>cat|cow|dog|sheep)|deer"
Local $sString = "hello" & @CRLF & _
"animals:" & @CRLF & _
"cow" & @CRLF & _
"cat" & @CRLF & _
"dog " & @CRLF & _
"sheep" & @CRLF & _
"deer "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")