const regex = /^(?<baseURL>https?:\/\/.+?)(?:\/(?:party(?:\/(?<partyId>[^/]+)(?:\/(?<partyView>game|results)?)?)?)?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<baseURL>https?:\\\/\\\/.+?)(?:\\\/(?:party(?:\\\/(?<partyId>[^\/]+)(?:\\\/(?<partyView>game|results)?)?)?)?)?$', 'gm')
const str = `http://wikirace.example.org
https://wikirace.example.org/
https://wikirace.example.org/party/asdfghj
https://wikirace.example.org/party/asdfghj/game
https://wikirace.example.org/party/asdfghj/results
https://example.org/wikirace/
http://example.org/wikirace/party
http://example.org/wikirace/game
https://wikirace.example.org/game/fghjhkl
https://example.org/wikirace/game/fghjhkl`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}