re = /^(?<baseURL>https?:\/\/.+?)(?:\/(?:party(?:\/(?<partyId>[^\/]+)(?:\/(?<partyView>game|results)?)?)?)?)?$/m
str = 'http://wikirace.example.org
https://wikirace.example.org/
https://wikirace.example.org/party/asdfghj
https://wikirace.example.org/party/asdfghj/game
https://wikirace.example.org/party/asdfghj/results
https://example.org/wikirace/
http://example.org/wikirace/party
http://example.org/wikirace/game
https://wikirace.example.org/game/fghjhkl
https://example.org/wikirace/game/fghjhkl'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end