re = /(\((?>[^()\\]++|\\.|(?1))*+\))|\b(2)(?=\b(?:,|\(|'|$))/m
str = '2(2\'Abf\',3),212,2\'abc\',2(1,2\'abd\',3)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end