#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:(?:25[0-5]|2[0-4][0-9]|1?[1-9][0-9]?|10[0-9])(?:(?<!\.)\b|\.))(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:(?<!\.)\b|\.)){3}"
Local $sString = "Match on VALID IP address anywhere in string." & @CRLF & _
"192.1683.0.1 1.1.1.256 3.2.6.2351 300.3.3.3 192.168.10.10 127.0.0.999" & @CRLF & _
"255.255.256.255 255.255.255.2555 100.0.0.1 1000.0.0.1" & @CRLF & _
"192.168.10.10" & @CRLF & _
"100.0.0.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")