use strict;
my $str = 'Match on VALID IP address anywhere in string.
192.1683.0.1 1.1.1.256 3.2.6.2351 300.3.3.3 192.168.10.10 127.0.0.999
255.255.256.255 255.255.255.2555 100.0.0.1 1000.0.0.1
192.168.10.10
100.0.0.1';
my $regex = qr/\b(?:(?:25[0-5]|2[0-4][0-9]|1?[1-9][0-9]?|10[0-9])(?:(?<!\.)\b|\.))(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:(?<!\.)\b|\.)){3}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}