use strict;
my $str = ' en août, ni sur ceux récoltés ensuite (16.10.2014, M. Garnier-Delcourt & J. Thorn), peut-être parce que les sporophores étaient un peu dégradés par les intempéries ? Cortinarius emollitoides Bidaud, MoënneLocc. & Reumaux (Fig. 2) = C. galeobdolon Melot sensu auct. ; C. causticus Fr. sensu. auct. non Brandrud et al. (1998) Ard. : Consthum, Fridbësch (71/113), plantation d’Abies et de Picea, 12.11.2012, Ch. Reckinger 319 (h) ; ibid., 23.9.2014, Ch. Reckinger 405 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h). Dans le sous-genre Myxacium (Fr.) Trog, qui regroupe en principe des cortinaires à chapeau et pied visqueux, la section Vibratiles Melot se distingue par l’amertume de la cuticule et généralement aussi de tout le sporophore. Elle comprend des espèces assez colorées (en jaune-brun ou rougebrun) ou peu co';
my $regex = qr/( ?ibid\., *(([0-3]?[0-9]\.)?[01]?[0-9]\.[0-9]{2,4}), *([^;]{0,50}) *(;|\) ?\.))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}