// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)( ?ibid\., *(([0-3]?[0-9]\.)?[01]?[0-9]\.[0-9]{2,4}), *([^;]{0,50}) *(;|\) ?\.))").unwrap();
let string = " en août, ni sur ceux récoltés ensuite (16.10.2014, M. Garnier-Delcourt & J. Thorn), peut-être parce que les sporophores étaient un peu dégradés par les intempéries ? Cortinarius emollitoides Bidaud, MoënneLocc. & Reumaux (Fig. 2) = C. galeobdolon Melot sensu auct. ; C. causticus Fr. sensu. auct. non Brandrud et al. (1998) Ard. : Consthum, Fridbësch (71/113), plantation d’Abies et de Picea, 12.11.2012, Ch. Reckinger 319 (h) ; ibid., 23.9.2014, Ch. Reckinger 405 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h) ; ibid., 23.9.2014, Ch. Reckinger 406 (h). Dans le sous-genre Myxacium (Fr.) Trog, qui regroupe en principe des cortinaires à chapeau et pied visqueux, la section Vibratiles Melot se distingue par l’amertume de la cuticule et généralement aussi de tout le sporophore. Elle comprend des espèces assez colorées (en jaune-brun ou rougebrun) ou peu co";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}