# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\((?:\(\d+\.\d(?: \d+)?\)(?: |(?=\)$)))+\)$/ /g;t' <<< "((1.0 4) (2.0 5) (33.2) (10.0 8))"