use strict;
my $str = '((1.0 4) (2.0 5) (33.2) (10.0 8))';
my $regex = qr/^\((?:\(\d+\.\d(?: \d+)?\)(?: |(?=\)$)))+\)$/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";