re = /^\((?:\(\d+\.\d(?: \d+)?\)(?: |(?=\)$)))+\)$/
str = '((1.0 4) (2.0 5) (33.2) (10.0 8))'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result