package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(ABCDEF|FEDCBA|AA-BB-CCCC|ABCDEFGH-IJK)$`)
var str = `ABCDEF
FEDCBA
AA-BB-CCCC
AA-BB-CCCC
ABCDEFGH-IJK`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}