re = /^(ABCDEF|FEDCBA|AA-BB-CCCC|ABCDEFGH-IJK)$/m
str = 'ABCDEF
FEDCBA
AA-BB-CCCC
AA-BB-CCCC
ABCDEFGH-IJK'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end