#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-z].*)(?=.*[A-Z].*)(?=.*[0-9].*)[a-zA-Z0-9]{6,32}$"
Local $sString = "Deve conter pelo menos uma letra maiúscula." & @CRLF & _
"Pelo menos uma minúscula" & @CRLF & _
"Pelo menos um número" & @CRLF & _
"O tamanho deve estar entre 6 e 32 caracteres" & @CRLF & _
"Não pode ter nenhum carácter especial ou espaço" & @CRLF & _
"Deve ter todos os 3 tipos: maiúsculas, minúsculas e números, não importa a ordem" & @CRLF & _
"" & @CRLF & _
"Match:" & @CRLF & _
"Mm01234" & @CRLF & _
"mM01234" & @CRLF & _
"01M23m4" & @CRLF & _
"Mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm1" & @CRLF & _
"" & @CRLF & _
"Invalidar:" & @CRLF & _
"Mm.0123" & @CRLF & _
"Mmmmmmm" & @CRLF & _
"m012345" & @CRLF & _
"M012345" & @CRLF & _
"0123456" & @CRLF & _
"MMMMMMM" & @CRLF & _
"Mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")