use strict;
my $str = 'Deve conter pelo menos uma letra maiúscula.
Pelo menos uma minúscula
Pelo menos um número
O tamanho deve estar entre 6 e 32 caracteres
Não pode ter nenhum carácter especial ou espaço
Deve ter todos os 3 tipos: maiúsculas, minúsculas e números, não importa a ordem
Match:
Mm01234
mM01234
01M23m4
Mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm1
Invalidar:
Mm.0123
Mmmmmmm
m012345
M012345
0123456
MMMMMMM
Mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm1';
my $regex = qr/^(?=.*[a-z].*)(?=.*[A-Z].*)(?=.*[0-9].*)[a-zA-Z0-9]{6,32}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}