import Foundation
let pattern = #"^(?=.*[a-z].*)(?=.*[A-Z].*)(?=.*[0-9].*)[a-zA-Z0-9]{6,32}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Deve conter pelo menos uma letra maiúscula.
Pelo menos uma minúscula
Pelo menos um número
O tamanho deve estar entre 6 e 32 caracteres
Não pode ter nenhum carácter especial ou espaço
Deve ter todos os 3 tipos: maiúsculas, minúsculas e números, não importa a ordem
Match:
Mm01234
mM01234
01M23m4
Mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm1
Invalidar:
Mm.0123
Mmmmmmm
m012345
M012345
0123456
MMMMMMM
Mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)