re = /([\w\.]+)(?!.*\1)/m
str = 'H. Gerhardstraat 77 1502 CC 77 1502 CC Zaandam
How are are you
I I I am fine'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end