re = /\[[^][]*]\s+\[[^][]*]\s+\[[^][]*]\s+\[[^][]*]\s+\[[^][]*]\s+\[(3)]\s+\[]\s+\[[^][]*]\s+\[[^][]*]\s+\[[^][]*]/m
str = '[1617620801] [0.0042] [domain.com] [#5006616] [269] [3] [] [403] [GET] [/study/index.php] [SQL injection] [hex:4745543a61203d203b2044524f50205441424c45203c]
[1617621606] [0.00205] [domain.com] [#2926762] [0] [2] [] [403] [POST] [/xmlrpc.php] [Access to WordPress XML-RPC API] [hex:2f786d6c7270632e706870]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end