import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)\\r?\\n[^\\S\\r\\n]+Uploaded on";
final String string = "\n"
+ " Update Your Profile to Dissolve This Message\n"
+ "Social Media Learning and behaviour\n"
+ " Uploaded on May 3, 2020 at 10:56 in Research\n"
+ " View Forum\n"
+ " \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}