const regex = /(.*)\r?\n[^\S\r\n]+Uploaded on/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\r?\\n[^\\S\\r\\n]+Uploaded on', 'gm')
const str = `
Update Your Profile to Dissolve This Message
Social Media Learning and behaviour
Uploaded on May 3, 2020 at 10:56 in Research
View Forum
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}