const regex = /(?<=Password: )[^\s]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Password: )[^\\s]*', 'gm')
const str = `Password: Wi!CYtB!%w8za (Please change it immediately!)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}