$re = '/(?<=Password: )[^\s]*/m';
$str = 'Password: Wi!CYtB!%w8za (Please change it immediately!)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);