using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s([\-\+\!]?)([\-\+\!]?)(?:([\'""])(.+?)\3)|([\-\+\!]?[\w\-#@\/\(\)]+)";
string input = @"+@bob ""xxx"",'yyy', ""freak'd out"" -'bob two' "" can I #handle/children -#nope @ok(42)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}