$re = '/(?P<type>BORDER)(?:::)(?P<desc>[\w#()/]*)/m';
$str = 'BORDER::APPLE_PEERING_GROUP_1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);