re = /(?P<type>BORDER)(?:::)(?P<desc>[\w#()\/]*)/m
str = 'BORDER::APPLE_PEERING_GROUP_1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end