package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)define ([a-zA-Z0-9- ]+?)(?:to be)`)
var str = `We define the difference of two sets A and B to be`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}