# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"class=\"[^\"]*(?<=\"|\s)col-xs-9(?=\"|\s[^>]*)\">(?<name>[^<]*)"
test_str = ("<div class=\"top_seller_name col-xs-9\">\n"
" Yusuf\n"
" \n"
" \n"
" <div class=\"sprite_view_icn_whatsapp top_seller_whatsapp_sprite\">\n"
" <div class=\"top_seller_whatsapp\">WhatsApp Preferred</div>\n"
" </div>\n"
" \n"
" </div>")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.