#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(ol|ul)([^>]*?)(type="[^"]*")([^>]*?)>"
Local $sString = "<ol type="a"><li></span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span><ol><li></span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span><ul type="i"><li ></span>In voluptate velit esse type="a" cillum dolore eu fugiat nulla pariatur.<ol style="abc" type="a">ádasdasd" & @CRLF & _
"<ol style="abc">sadas</ol><ol style="abc" type="a" abc="ee">sadas</ol><ol type="a" abc="ee">sadas</ol>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")