$re = '/^[+-]?[0-9]+(?:,[0-9]+)*(?:\.[0-9]+)?$/m';
$str = '111
1.11
1,111
1,111.01
+111
+1.11
+1,111
+1,111.01
-111
-1.11
-1,111
-1,111.01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);