#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\-?\d*\-?\d+)\/(\d+$))|(^\-?\d+$)"
Local $sString = "/ in str" & @CRLF & _
"3/5" & @CRLF & _
"33/55" & @CRLF & _
"-3/5" & @CRLF & _
"-33/55" & @CRLF & _
"/ not in str" & @CRLF & _
"3" & @CRLF & _
"-3" & @CRLF & _
"33" & @CRLF & _
"-33" & @CRLF & _
"carry" & @CRLF & _
"1-1/2" & @CRLF & _
"-1-1/2" & @CRLF & _
"#invalid" & @CRLF & _
"/" & @CRLF & _
"-" & @CRLF & _
"3/" & @CRLF & _
"/33" & @CRLF & _
"3-3" & @CRLF & _
"1-/2" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")