using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(?:-\d+)?')? (\D+) (\d+)";
string input = @"20' Container 1, 40' Open Container 1, 40-45' Closed Container 3, container roll 10, container lift 50";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}