# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*-----BEGIN PGP MESSAGE-----\s*(?:(?:Charset:.*\n)|(?:Version:.*\n)|(?:Comment:.*\n))*\s*(?:(?:[A-Za-z0-9+\/]{4}\n?)*(?:[A-Za-z0-9+\/]{2}==|[A-Za-z0-9+\/]{3}=))\n(?:=(?:[A-Za-z0-9+\/]{4}\n?)?)\s*-----END PGP MESSAGE-----\s$"
test_str = ("-----BEGIN PGP MESSAGE-----\n"
"Version: OpenPGP.js v4.10.4\n"
"Comment: https://openpgpjs.org\n\n"
"wV4DvfxLq4XF8ggSAQdA4vSDKaF+rOKWmS/JG36qiH9AxUZoAIbCw922l2lG\n"
"2C4w/KefQjcbu+Tv3ymV0Dtfm3702tWK6CIiMr0cCu7iBfZqZ7JOEaOJfEzz\n"
"0NoSwo080kIBHSs5HLQOj89Ra0A2QgHKV5lsOZGDVlpgZZjQFGL+p+Vc/hJT\n"
"+Moh7JGYof6YD4u9ueDWCbgSXbMsvbWcitjnjdU=\n"
"=wC/C\n\n"
"-----END PGP MESSAGE-----\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.