re = /^\s*-----BEGIN PGP MESSAGE-----\s*(?:(?:Charset:.*\n)|(?:Version:.*\n)|(?:Comment:.*\n))*\s*(?:(?:[A-Za-z0-9+\/]{4}\n?)*(?:[A-Za-z0-9+\/]{2}==|[A-Za-z0-9+\/]{3}=))\n(?:=(?:[A-Za-z0-9+\/]{4}\n?)?)\s*-----END PGP MESSAGE-----\s$/
str = '-----BEGIN PGP MESSAGE-----
Version: OpenPGP.js v4.10.4
Comment: https://openpgpjs.org
wV4DvfxLq4XF8ggSAQdA4vSDKaF+rOKWmS/JG36qiH9AxUZoAIbCw922l2lG
2C4w/KefQjcbu+Tv3ymV0Dtfm3702tWK6CIiMr0cCu7iBfZqZ7JOEaOJfEzz
0NoSwo080kIBHSs5HLQOj89Ra0A2QgHKV5lsOZGDVlpgZZjQFGL+p+Vc/hJT
+Moh7JGYof6YD4u9ueDWCbgSXbMsvbWcitjnjdU=
=wC/C
-----END PGP MESSAGE-----
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end