#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s*Page \d+ of \d+\s*"
Local $sString = "thisisaboutthen" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Page 2 of 12" & @CRLF & _
"" & @CRLF & _
"nowwearegoing" & @CRLF & _
"" & @CRLF & _
"Page 3 of 12" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)