const regex = new RegExp('\\s*Page \\d+ of \\d+\\s*', 'g')
const str = `thisisaboutthen
Page 2 of 12
nowwearegoing
Page 3 of 12
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);