$re = '/\s*Page \d+ of \d+\s*/';
$str = 'thisisaboutthen
Page 2 of 12
nowwearegoing
Page 3 of 12
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;