re = />> ([a-zA-Z ]+)(?=:)/m
str = '>> John doe: Hello, I am John Doe. >> Hello, I am Jane Doe. >> Thank you for coming, we will start in two minutes. >> Sam Smith: [no audio] Good morning, everyone.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end