#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)# Horizontal grid." & @CRLF & _
"(?<=\|\s|\|\s:)(-+)(?=:?\s\|)" & @CRLF & _
"|" & @CRLF & _
"" & @CRLF & _
"# Vertical grid." & @CRLF & _
"((?<=\|\s):|:(?=\s\|))" & @CRLF & _
"|" & @CRLF & _
"" & @CRLF & _
"# Header colon." & @CRLF & _
"((?<=^)\|(?=\s)|(?<=\s)\|(?=$)|\|(?=\s+.+\s+\|))"
Local $sString = "# Time block" & @CRLF & _
"" & @CRLF & _
"| Time | Block |" & @CRLF & _
"| ----------: | :---------------- |" & @CRLF & _
"| (00:00) | (Revision #1) |" & @CRLF & _
"| | |" & @CRLF & _
"| 00:00-00:00 | Chunk |" & @CRLF & _
"| | - Note w/ details |" & @CRLF & _
"| 00:00-00:00 | Some meeting |" & @CRLF & _
"| 11:00-13:00 | Chunk |" & @CRLF & _
"| | - Note w/ details |" & @CRLF & _
"| | |" & @CRLF & _
"| (00:00) | (Revision #1) |" & @CRLF & _
"| 00:00-00:00 | Chunk |" & @CRLF & _
"| | - Note w/ details |" & @CRLF & _
"" & @CRLF & _
"# Todo " & @CRLF & _
"" & @CRLF & _
"| Tracker | Task | Backlog |" & @CRLF & _
"| ----------: | :------------- | :------------ |" & @CRLF & _
"| 00:00-00:00 | [x] Task one | [[wiki.link |" & @CRLF & _
"| 00:00-00:00 | | |" & @CRLF & _
"| 0m | | |" & @CRLF & _
"| | | |" & @CRLF & _
"| | [<] Task two | [[wiki.link]] |" & @CRLF & _
"| | [<] Task three | [[wiki.link]] |" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")