using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"# Horizontal grid.
(?<=\|\s|\|\s:)(-+)(?=:?\s\|)
|
# Vertical grid.
((?<=\|\s):|:(?=\s\|))
|
# Header colon.
((?<=^)\|(?=\s)|(?<=\s)\|(?=$)|\|(?=\s+.+\s+\|))";
string input = @"# Time block
| Time | Block |
| ----------: | :---------------- |
| (00:00) | (Revision #1) |
| | |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
| 00:00-00:00 | Some meeting |
| 11:00-13:00 | Chunk |
| | - Note w/ details |
| | |
| (00:00) | (Revision #1) |
| 00:00-00:00 | Chunk |
| | - Note w/ details |
# Todo
| Tracker | Task | Backlog |
| ----------: | :------------- | :------------ |
| 00:00-00:00 | [x] Task one | [[wiki.link |
| 00:00-00:00 | | |
| 0m | | |
| | | |
| | [<] Task two | [[wiki.link]] |
| | [<] Task three | [[wiki.link]] |
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}