# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
# Horizontal grid.
(?<=\|\s|\|\s:)(-+)(?=:?\s\|)
|
# Vertical grid.
((?<=\|\s):|:(?=\s\|))
|
# Header colon.
((?<=^)\|(?=\s)|(?<=\s)\|(?=$)|\|(?=\s+.+\s+\|))
"""
test_str = ("# Time block\n\n"
"| Time | Block |\n"
"| ----------: | :---------------- |\n"
"| (00:00) | (Revision #1) |\n"
"| | |\n"
"| 00:00-00:00 | Chunk |\n"
"| | - Note w/ details |\n"
"| 00:00-00:00 | Some meeting |\n"
"| 11:00-13:00 | Chunk |\n"
"| | - Note w/ details |\n"
"| | |\n"
"| (00:00) | (Revision #1) |\n"
"| 00:00-00:00 | Chunk |\n"
"| | - Note w/ details |\n\n"
"# Todo \n\n"
"| Tracker | Task | Backlog |\n"
"| ----------: | :------------- | :------------ |\n"
"| 00:00-00:00 | [x] Task one | [[wiki.link |\n"
"| 00:00-00:00 | | |\n"
"| 0m | | |\n"
"| | | |\n"
"| | [<] Task two | [[wiki.link]] |\n"
"| | [<] Task three | [[wiki.link]] |\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.