package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(,\d{3})*$`)
var str = `123,700
123
1
123,700,123,700`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}