import Foundation
let pattern = #"\*([a-zA-Z ]+)\*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
What kind of *vegetable* is it?
I hope I am not late.
All *the good* shows are *no longer* broadcasting.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<b>$1</b>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)