#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.)(.*?)*?\1"
Local $sString = "abbcabb" & @CRLF & _
"abca"
Local $sSubst = "\g<2>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)